Subscribe or Renew Membership Subscribe Renew

blade stuck in 7 1/4 porter cable saw

Craig530's picture

About a year ago I replaced my old Milwaukee circular saw with a new Porter Cable that has a wrenchless blade nut.  It ( the blade nut) was a great improvement allowing blade changes without keeping a 9/16 ths wrench in your pouches.  However, the last time I tried to remove the blade nut it just spins loosely, without moving the bolt, and yes  I am holding the spindle lock and have been a carpenter for over 20 years so I can change blades in my sleep.  If anyone has a fix for this problem let me know. 


Thanks

(post #80644, reply #1 of 9)

did you try throwing it off the roof swearing. :)'


 


It takes studs to build a house

(post #80644, reply #2 of 9)

only swearing that I will never buy another saw with a wrenchless blade bolt

(post #80644, reply #3 of 9)

lol

 


It takes studs to build a house

(post #80644, reply #4 of 9)

Maybe you can "spin" the blade in the undoing direction. Have someone hold the saw body and you place a "spike" in the blade some how and give it a thump. Get the idea?

(post #80644, reply #7 of 9)

lock washer has flat sides on not a round hole spinning blade can only spin shaft not retaining bolt

(post #80644, reply #5 of 9)

Try an impact gun.  The "slapping" action will often knock the bolt loose.  Has worked for me in the past on older saws w/out the shaft-lock.


Good luck.


Live in the solution, not the problem.

The best reward for a job well done is the opportunity to do another.

(post #80644, reply #6 of 9)

I'd take it to the service center myself.  I think that was a problem, also you should see if it was recalled for the guard sticking.  Mine is a bit odd about blade changes too, but it works.  I don't really see an advantge to it.

(post #80644, reply #8 of 9)

This won't help your current dilemma, but as I live in the PNW where it tends to be damp in the winter, I always give removeable bolts and nuts a dab of Never-seize compound before reassembly.


Personally, I'm not too fond of tool-less blade changing systems.  The last one I dealt with was on one of my sawzalls....the sleeve inside had shattered and getting the blade out and getting it apart was a real MFr.

Same Issue! (post #80644, reply #9 of 9)

So, I have the exact same issue. Were you able to finally remove the blade and get the quick re;ease working again?

 

thanks!